Wednesday, August 31, 2011

OSPF sobre Frame-Relay Parte 2


Vamos ver uma outra forma de integrar OSPF com Frame-Relay, porém , dessa vez, usaremos a nuvem Frame-Relay presente no Packet Tracer.
  como já discutimos no post anterior, OSPF usa multicast por defaul para montar sua topologia livre de loops, anviando informações para o IP 224.0.0.5, enquanto Frame-Relay é uma tecnologia NBMA, Non-Broadcast Multi-Acccess. Como o multicast é um tipo de Broadcast, temos a situação problema que iremos estudar.

Abaixo segue nossa rede :





  Nessa nossa topologia, temos o router MG conectado ao router ES através da nuvem Frame-Relay.
Vamos ver nossas configurações, a partir do router MG:


Iniciaremos com Boas práticas, configurando segurança em nosso router:

Router>
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname MG
MG(config)#line vty 0 4
MG(config-line)#password cisco

MG(config-line)#login
MG(config-line)#line con 0
MG(config-line)#password cisco
MG(config-line)#login


Em seguida, vamos configurar nossa interface serial:

MG(config-line)#exit
MG(config)#interface serial 2/0
MG(config-if)#ip address 1.1.1.1 255.255.255.0
MG(config-if)#encapsulation frame-relay 

MG(config-if)#frame-relay interface-dlci 16
MG(config-if)#frame-relay map ip 1.1.1.2 16 broadcast
MG(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

MG(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up


Vamos salvar sempre nossas configurações:

MG#
%SYS-5-CONFIG_I: Configured from console by console

MG#copy run start


Já vamos configurar o processo OSPF:

MG#config t
Enter configuration commands, one per line.  End with CNTL/Z.
MG(config)#
MG(config)#router ospf 1
MG(config-router)#net
MG(config-router)#network 1.1.1.0 0.0.0.255 area 0
MG(config-router)#


Iremos agora para o router ES:

Faremos da mesma forma,segurança e em seguida interface e OSPF:

Router>en
Router#
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname ES
ES(config)#line vty 0 4
ES(config-line)#password cisco
ES(config-line)#login
ES(config-line)#line con 0
ES(config-line)#password cisco


ES(config-line)#login
ES(config-line)#exit
ES(config)#
ES(config)#interface serial 2/0
ES(config-if)#ip add 1.1.1.2 255.255.255.0
ES(config-if)#encapsulation frame-relay
ES(config-if)#frame-relay interface-dlci 19
MG(config-if)#frame-relay map ip 1.1.1.2 16 broadcast
ES(config-if)#



%LINK-5-CHANGED: Interface Serial2/0, changed state to up

ES(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up


Já podemos então pingar nosso outro router, vamos ver?

ES#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 47/59/62 ms

Perfeito!

Agora em router MG:

MG#
MG#ping 1.1.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 62/62/63 ms


Ótimo também...

Se temos ping, podemos ver então como está nosso OSPF.


MG#sh  ip ospf neighbor

Nenhum Vizinho!



MG#show ip ospf database
            OSPF Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         68          0x80000001 0x00d267 1


Apenas ele mesmo.


MG#show ip protocols

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    1.1.1.0 0.0.0.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)

Apenas ele mesmo.

Ou seja, não  precisamos nem olhar no router ES para saber que não temos convergência OSPF.

Vamos ver um outro comando:

MG#show ip ospf interface serial 2/0
Serial2/0 is up, line protocol is up
  Internet address is 1.1.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type MULTI-POINT, Cost: 781
  Transmit Delay is 1 sec, State WAITING, Priority 1
  No designated router on this network
  No backup designated router on this network
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 00:00:00
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
MG#


Na linha em destaque, temos uma informação importante. O OSPF está enxergando a rede como Multi-point, ou seja, ele irá tentar formar as adjacências enviando os pacotes Hello.

Dessa forma, podemos alterar a maneira como ele enxerga a rede, uma vez que nós sabemos que em nossa topologia, não haverá necessidade de eleição de DR e BDR.

Para fazer isso, entramos com o seguinte comando:

MG(config-if)#ip ospf network point-to-point

  Em ambos os routers:

ES(config-if)#ip ospf network point-to-point




Resultado:

MG:

MG(config-if)#
00:31:11: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.2 on Serial2/0 from LOADING to FULL, Loading Done


 ES:


ES(config-if)#
00:25:32: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial2/0 from LOADING to FULL, Loading Done

Agora assim temos a rede convergida, podemos repetir os comando em MG:

MG#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.2           0   FULL/  -        00:00:31    1.1.1.2         Serial2/0

MG#show ip ospf database
            OSPF Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         333         0x80000004 0x007f90 2
1.1.1.2         1.1.1.2         333         0x80000004 0x00739a 2


MG#sh ip protocols

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    1.1.1.0 0.0.0.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    1.1.1.2              110      00:05:55
  Distance: (default is 110)
Mais uma situação em que é possível ter essas duas tecnologias interoperando sem problemas desde que se conheça suas nuâncias.

 












No comments:

Post a Comment

Note: Only a member of this blog may post a comment.